2021. 3. 2. 16:36 ANDROID IOS
인텔리제이 (안드로이드스튜디오) 안드로이드 프로젝트 모듈설정 그래들 싱크, IntelliJ (Android Studio) No Module Gradle Sync

인텔리제이에서 안드로이드 앱 프로젝트를 열었는데 모듈이 없을때

해결방법 입니다.

 

프로젝트 구조가 올바른 상태였어야 합니다.

당연히 되도않는 소스만 가지고는 모듈을 설정할 수 없습니다.

 

안드로이드 스튜디오도 같은 방식으로 설정하면 됩니다.

(Gradle Sync가 메뉴>Files에 있다는...)

 

 

증상1

이렇게 디버깅 툴바에 빌드버튼만 덩그러니 있습니다.

 

증상2

Add Configuration...눌러서 Android App에 가보면 모듈이 없습니다.

 

 

 

1. Gradle 탭을 열어서 리프레시버튼을 클릭합니다.

Reload All Gradle Projects

 

 

2. 메뉴 > Tools > Android > Sync Project with Gradle Files 선택

 

 

3. 모듈이 추가되서 앱을 인식하게 됩니다.

댓글을 달아 주세요

2020. 10. 19. 13:29 DEV ENVIRONMENT
인텔리제이에서 안드로이드 네이티브 템플릿 가져오기, Intellij Import Native Template Module

이제 안드로이드 스튜디오를 안쓰고 인텔리제이에서 안드로이드 개발을 하고 있습니다.
그래서그런지 메뉴명이 조금씩 틀립니다. (버전이 다른건지...)

 

어쨌든 구글 애드몹 네이티브 광고 달기 예제에 네이티브템플릿을 모듈가져오기로 임포트 하라는데,
인텔리제이는 조금 다릅니다.

 

 

1. File > New > Module...

 

 

2. New Module > Android > Import Gradle Project

Source directory 선택 (.gradle이 있는 디렉토리 선택, nativetemplates)

 

 

3. 그래들 싱크가 끝나면 정상적으로 임포트 된 모듈을 확인할 수 있습니다.

 

 

댓글을 달아 주세요

2020. 10. 3. 17:39 ANDROID IOS
안드로이드 그래들 변경, Upgrade Gradle wrapper to 2.6 version and re-import the project, Android Upgrade Gradle Version

깃허브에서 받은 프로젝트를 돌려볼라고 했는데,

그래들 2.6은 삭제되었다고 에러가 발생했습니다.

해결하려면 그래들을 최신 버전으로 변경해주면 됩니다.
(오래된 프로젝트 소스라면 이부분 말고도 더 많이 변경해야할 수 있습니다...)

 

Support for builds using Gradle versions older than 2.6 was removed in tooling API version 5.0. You are currently using Gradle version 2.2.1. You should upgrade your Gradle build to use Gradle 2.6 or later.

Possible solution:
 - Upgrade Gradle wrapper to 2.6 version and re-import the project

 

 

1. 프로젝트 > gradle > wrapper > gradle-wrapper.properties 파일 열기

 

 

2. gradle-x.x.x.zip > gradle-6.3-all.zip 으로 수정

distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip

 

 

3. 그래들 싱크, Load Gradle Changes, Ctrl+Shift+O

댓글을 달아 주세요

2020. 9. 24. 09:51 ANDROID IOS
안드로이드 그래들 오류, Could not initialize class org.codehaus.groovy.runtime.InvokerHelper, Android Gradle Error
Could not initialize class org.codehaus.groovy.runtime.InvokerHelper

하라는 빌드는 안하고 이런 오류가 발생하면서 멈출때가 있습니다.

저같은 경우에는 그래들 버전이랑 자바버전이랑 안맞아서 발생했습니다.

 

 

1. gradle\wrapper\gralde-wrapper.properties
그래들 버전이 6.1.1입니다.

지금 최신버전인 6.3으로 변경

distributionUrl=https\://services.gradle.org/distributions/gradle-6.1.1-all.zip

distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-all.zip

 

 

2. Project Structure > Project Settings > Project
Project SDK가 자바 11로 되어있습니다.

14버전으로 변경

ㅁㄴㅇㄹ

 

3. gradle\wrapper\gralde-wrapper.properties

파일을 열고 그래들 싱크

Gradle Sync: Ctrl+Shift+O

 

 

빌드 됨

 

댓글을 달아 주세요

최근에 올라온 글

최근에 달린 댓글